MacOS Catalina (macOS 10.15) introduces new requirements for apps. It also drops support of 32-bit apps, such as Plane Maker 10, entirely.

Catalina & X-Plane 10

If you are using X-Plane 10, we recommend that you do not update to macOS Catalina. The X-Plane 10 installer, Plane Maker, and Airfoil Maker apps will no longer work on this version of the Mac operating system.

Catalina & X-Plane 11

The X-Plane team is still testing macOS Catalina with X-Plane 11, but does not anticipate any major issues at this time.

The X-Plane 11 Professional-Use USB key will require updated HASP drivers, available here, to work on macOS Catalina.

Return Back to Knowledge Base





X-Plane

The world’s most advanced flight simulator.